Resolved
This incident is resolved. Dashboard access is working as usual.
As noted earlier, this incident only affected the dashboard and had no impact on turbopuffer regions or namespaces!
Monitoring
Traffic has returned to normal. We're monitoring closely!
Monitoring
We're seeing recovery with traffic returning to normal. We're monitoring closely and will share another update shortly.
Identified
This issue is currently affecting the dashboard and API key management. turbopuffer regions and namespaces are all operating normally, and existing API keys continue to authenticate as expected.
The root cause is a dependency service that we use for metadata. We'll share an update as we make progress.
Investigating
We've confirmed reports of dashboard errors and are actively investigating. Note that the database is not affected - this issue is limited to the dashboard.