Resolved
The region has stabilized and returned to normal operation. We are continuing to monitor!
Monitoring
A fix has been rolled out and 5xx errors in the region have reduced. We are continuing to monitor the situation!
Investigating
We are investigating an increase 500's in the region!