Resolved
Service has returned to normal. The cause has been identified and is being addressed.
Monitoring
We've identified the problem and taken action to stop customer impact.
Investigating
Customers may notice a small number of their requests receiving a 500 response due to transient unavailability of turbopuffer query nodes. We have identified a probable cause and are moving to confirming and addressing it.