Resolved
The issue has been resolved. We deployed a fix and confirmed that affected nodes have returned to normal operation.
Monitoring
We identified an issue causing high CPU utilization on a subset of query nodes in us-west-2. Some customers experienced 429 errors and increased query latency during this time.
We have identified the root cause and are deploying a fix. We are actively monitoring the situation and implementing additional safeguards to prevent this from recurring.