Resolved
Latencies have remained stable.
Monitoring
The region has fully transitioned back to Intel hardware and API response latency has returned to normal. We're monitoring to ensure that latencies remain stable.
Identified
We've identified a pathological performance issue when running on ARM hardware. We've shifted the region to run entirely on Intel hardware.
Investigating
We're investigating reports of degraded performance in aws-us-west-2.